This forum is no longer active. Please post your questions to our new community site

upgrading rails to 2.1 windows

Subscribe to upgrading rails to 2.1 windows 9 post(s), 5 voice(s)

 
Avatar thunderkel 6 post(s)

Is there a procedure to do this manually on windows ?

 
Avatar Manu 50 post(s)

Hi,

Yes, you can update rails to 2.1.0 version. You must to run rubyconsole in ‘Start>Programs>BitNami Rubystack>Use BitNami Rubystack’ (right click>run as administrator) and type the following:

gem update rails

This action will update actionpack, actionmailer, activeresource and rails gems to 2.1.0 version.

I hope it helps you.

Cheers,
Manu.

 
Avatar thunderkel 6 post(s)

Is there anything else I need to do…I had a working app – I did a ruby gems update and a gem update rails.
I now get the following when I try to start a server.

Did I make a mistake by updating the gems ? is there an easy way to correct this ?

Exiting
C:/PROGRA1/BITNAM1/ruby/lib/ruby/site_ruby/1.8/rubygems/requirement.rb:150:in
`parse’: Illformed requirement [{:version=>”>= 0.9.0”}] (ArgumentError) from C:/PROGRA1/BITNAM1/ruby/lib/ruby/site_ruby/1.8/rubygems/requireme
nt.rb:75:in `initialize’ from C:/PROGRA1/BITNAM1/ruby/lib/ruby/site_ruby/1.8/rubygems/requireme
nt.rb:74:in `map’ from C:/PROGRA1/BITNAM1/ruby/lib/ruby/site_ruby/1.8/rubygems/requireme
nt.rb:74:in `initialize’ from C:/PROGRA1/BITNAM1/ruby/lib/ruby/site_ruby/1.8/rubygems/requireme
nt.rb:45:in `new’ from C:/PROGRA1/BITNAM1/ruby/lib/ruby/site_ruby/1.8/rubygems/requireme
nt.rb:45:in `create’ from C:/PROGRA1/BITNAM1/ruby/lib/ruby/site_ruby/1.8/rubygems/dependenc
y.rb:59:in `initialize’ from C:/PROGRA1/BITNAM1/ruby/lib/ruby/site_ruby/1.8/rubygems.rb:130:in `new’ from C:/PROGRA1/BITNAM1/ruby/lib/ruby/site_ruby/1.8/rubygems.rb:130:in `activate’ ... 30 levels… from C:/PROGRA1/BITNAM1/ruby/lib/ruby/gems/1.8/gems/rails-2.0.2/lib/co
mmands/server.rb:39 from C:/PROGRA1/BITNAM1/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_re
quire.rb:27:in `gem_original_require’ from C:/PROGRA1/BITNAM1/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_re
quire.rb:27:in `require’ from script/server:3

 
Avatar carlos Administrator 144 post(s)

Hello thunderkel,

Can you check if you have the constant RAILS_GEM_VERSION defined in config/environment.rb ? You should modify it to be:

RAILS_GEM_VERSION = '2.1.0' unless defined? RAILS_GEM_VERSION

If it doesn’t work with that change you can try to update rubygems by calling:

gem update --system
and updating the gems once again.

Have you any “config.gem” call in your code ?

 
Avatar HenryS 5 post(s)

Just came to the forum to ask rails 2.1 question :-). But I need something extra:

My PC, where I need rails 2.1 is not (and never will be) connected to Internet. So I need to move downloaded gem to the PC first and then install it with -l switch.

So, what else should I download to have rails 2.1 working within BitNami Stack without headache?
(I have WinXP-SP2 with RubyStack -0 currently)

Thank you in advance.

 
Avatar Beltrán Rueda Administrator 3,714 post(s)

Yes, these are the steps to upgrade rails without internet connection. You should not have any problem but you can post here and we will try to reply your question :)

 
Avatar HenryS 5 post(s)

Thank you for reply.

Trying to clarify my concern regarding internetless rails 2.1 installation.

1. Should I upgrade to 1.1-1 (which is NOT rails 2.1) first?

2. Has the Stack some extra stuff non-recognizible by the standard gem command, so I would not notice potential problems, keeping Stack-specific things non-upgraded to comply with Rails 2.1.

It will be difficult to catch the problem later.

 
Avatar Beltrán Rueda Administrator 3,714 post(s)

Hi,

See below for answers to your questions

1. Should I upgrade to 1.1-1 (which is NOT rails 2.1) first?

No, it is not necessary.

2. Has the Stack some extra stuff non-recognizible by the standard gem command, so I would not notice potential problems, keeping Stack-specific things non-upgraded to comply with Rails 2.1.

I think that you should not have any problem upgrading rails 2.1. I only typed “gem update rails” in the rubyconsole and everything runs well. You have take into account the previous Carlos post, you should modify the RAILS_GEM_VERSION in your config/environment.rb configuration file.

I hope it helps.

 
Avatar HenryS 5 post(s)

Tnank you.
Hope to try it on separate folder