This forum is no longer active. Please post your questions to our new community site

Web server error

Subscribe to Web server error 2 post(s), 2 voice(s)

 
Avatar Carlos V 1 post

I am getting the following error when I try to boot the server:

=> Booting Mongrel
=> Rails 2.3.2 application starting on http://0.0.0.0:3000
=> Call with -d to detach
=> Ctrl-C to shutdown server
Exiting
/System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/gems/1.8/gems/mongrel-1.1.4/lib/mongrel/tcphack.rb:12:in `initialize_without_backlog’: Address already in use – bind(2) (Errno::EADDRINUSE) from /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/gems/1.8/gems/mongrel-1.1.4/lib/mongrel/tcphack.rb:12:in `initialize’ from /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/gems/1.8/gems/mongrel-1.1.4/lib/mongrel.rb:93:in `new’ from /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/gems/1.8/gems/mongrel-1.1.4/lib/mongrel.rb:93:in `initialize’ from /Library/Ruby/Gems/1.8/gems/actionpack-2.3.2/lib/action_controller/vendor/rack-1.0/rack/handler/mongrel.rb:10:in `new’ from /Library/Ruby/Gems/1.8/gems/actionpack-2.3.2/lib/action_controller/vendor/rack-1.0/rack/handler/mongrel.rb:10:in `run’ from /Library/Ruby/Gems/1.8/gems/rails-2.3.2/lib/commands/server.rb:111 from /Library/Ruby/Site/1.8/rubygems/custom_require.rb:31:in `gem_original_require’ from /Library/Ruby/Site/1.8/rubygems/custom_require.rb:31:in `require’ from script/server:3

Any help?

 
Avatar Beltrán Rueda Administrator 3,714 post(s)

Hi,

It seems that your application or a different application is running at the same port. Could you try to check if there is any ruby application running in the 3000 port?

$ ps aux | grep ruby

Try to kill using the pid and restart it.

$ kill -9 PID

Cheers.