This forum is no longer active. Please post your questions to our new community site

Forums Subversion

svn: Authentication error from server: Username not found

Subscribe to svn: Authentication error from server: Username not found 5 post(s), 2 voice(s)

 
Avatar c4rdinal 12 post(s)

Hi,

I installed bitnami-redmine-0.9.3.0-linux-installer stack but can’t import anything in svn repo. The error shows:

root@pro:/opt/redmine-0.9.3-0# svn import /home/administrator/projects svn://192.168.125.1/home/projects/svn -m “Projects”
Authentication realm: <svn://192.168.125.1:3690> 99e8aa98-e6fd-43fe-b166-9ddbee0c8c14
Password for ‘root’:
Authentication realm: <svn://192.168.125.1:3690> 99e8aa98-e6fd-43fe-b166-9ddbee0c8c14
Username: admin
Password for ‘admin’:
Authentication realm: <svn://192.168.125.1:3690> 99e8aa98-e6fd-43fe-b166-9ddbee0c8c14
Username: user
Password for ‘user’:
svn: Authentication error from server: Username not found

I created a user in linux

#useradd user
#passwd pass

svnserce.conf

[general]
anon-access = read
auth-access = write
password-db = passwd

[users]
user = pass

and restarted svn. But still have no progress.

Please enlighten me. i’m stack for a week now.

Thanks

 
Avatar c4rdinal 12 post(s)

I fixed the error. The problem was i included [users] and [general] setting in svnserce.conf were it should not be the case.

However, i still got this error:

Checking out on tortoise:

Checkout from http://192.168.125.1/home/svnroot/project_dir, revision HEAD, Fully recursive, Externals included
OPTIONS of ‘http://192.168.125.1/home/svnroot/project_dir’: 200 OK (http://192.168.125.1)

I changed the svn root to /home/svnroot/project_dir via

  1. svnadmin create /home/svnroot
  2. mkdir /home/svnroot/project_dir
  3. svn import /home/administrator/projA svn://192.168.125.101/home/svnroot/project_dir/ -m “projA”

Please help.

Thanks

 
Avatar c4rdinal 12 post(s)

correction above: it should be:

I changed the svn root to /home/svnroot/project_dir via

1. svnadmin create /home/svnroot 2. mkdir /home/svnroot/project_dir 3. svn import /home/administrator/projA svn://192.168.125.1/home/svnroot/project_dir/ -m “projA”

Please help.

 
Avatar c4rdinal 12 post(s)

correction above: it should be:

I changed the svn root to /home/svnroot/project_dir via

1. svnadmin create /home/svnroot 2. mkdir /home/svnroot/project_dir 3. svn import /home/administrator/projA svn://192.168.125.1/home/svnroot/project_dir/ -m “projA”

Please help.

 
Avatar Beltrán Rueda Administrator 3,714 post(s)

Hi,

It is necessary to configure the Subversion server to use the new repository. Try to modify the following line installdir/apps/subversion/scripts/ctl.sh:

svnserve -d -r subversion_repository_path —listen-port=… —pid-file=…

Forums Subversion