This forum is no longer active. Please post your questions to our new community site

Forums SugarCRM

timeouts on mass update

Subscribe to timeouts on mass update 5 post(s), 2 voice(s)

 
Avatar saqqara 5 post(s)

When I try to delete a few thousand records I’ve imported via the Sugar gui, or mass update them, the web page times out. I have to go back and refresh, and find that my update/deletion only did about 1/3 of the records. This would seem to be an apache setting?

 
Avatar Beltrán Rueda Administrator 3,714 post(s)

Hi,

You can increase the timeout in the php.ini file (installdir/php/etc/php.ini)

max_execution_time = 120

 
Avatar saqqara 5 post(s)

Thanks. This didn’t seem to work. I edited that value in /opt/bitnami/php/etc/php.ini and restarted using /opt/bitnami/ctlscript.sh restart. Even though I set the value to 480 seconds it seems to time out after two minutes when I do a mass update.

Some other values I have changed in php.ini seem to help other problems so I don’t think it’s that I don’t know how to edit the file.

Specifically to be able to load modules without timing out I’ve had to change to these two values.

post_max_size=1024M
upload_max_size=1000M

You may wish to make these or similar changes to your distribution.

 
Avatar saqqara 5 post(s)

For the module loader to work properly I have also had to change the following setting:
short_open_tag=off

change to:
short_open_tag=on

(Still have the timeout problem that I originally posted, but want to share resolutions that have taken me hours of googling to find)

 
Avatar Beltrán Rueda Administrator 3,714 post(s)

Thanks for posting them :)

Forums SugarCRM