This forum is no longer active. Please post your questions to our new community site

Forums SugarCRM

upgrade to version 5.5

Subscribe to upgrade to version 5.5 11 post(s), 4 voice(s)

 
Avatar principe 4 post(s)

Hi,
when can we expect stack with the latest version – 5.5 ?

I’ve tried to upgrade the linux stack but nothing happens after uploading the ZIP file, it just return me to index page.

 
Avatar Beltrán Rueda Administrator 3,714 post(s)

Thanks for letting us know, we will try to update soon.

 
Avatar misterq 3 post(s)

And soon is approximately when?

 
Avatar Beltrán Rueda Administrator 3,714 post(s)

Hi,

We updated SugarCRM to 5.5.0 on December the 23th, two days later of this post :)

 
Avatar misterq 3 post(s)

That would appear to be a re-install – is there an upgrade?

 
Avatar Beltrán Rueda Administrator 3,714 post(s)

To update the application you have two options:

1. Install the new Stack and backup/restore the database. You can find a quick guide at https://bitnami.com/article/how-to-backup-and-up…
Although this guide is for Redmine application, the backup/restore is similar.

2. Download the source code of the new application, copy in the apps/sugarcrm/htdocs folder and follow the upgrade steps that the application requires.

Cheers

 
Avatar inthecards 3 post(s)

I am using a MAMP base withe SugarCRM 5.5stack. Recently SugarCRM released version 5.51. According to the instructions provided by SugarCRM for upgrading to version 5.51, two changes to the php.ini file must be made.

1) post_max_size must be changed from 6M to 20MB or greater.
2) upload_max_filesize must be changed from 6M to 20MB or greater.

Once I made these two changes I noticed that ySQL started to time out repeatedly or cause other errors, to solve the problem I had to return back to the origional php.ini settings.

Is there something I am missing? The instructions for the upgrade can be found here – http://www.sugarcrm.com/crm/support/documentati…

thank you in advance.

 
Avatar Beltrán Rueda Administrator 3,714 post(s)

Hi,

It seems that it requires also to increase the MySQL maximum allowed packet. Try to add this value in the"_installdir_/mysql/my.cnf" (or my.ini for Windows) file and restart the database.

max_allowed_packet = 20M

 
Avatar inthecards 3 post(s)

It worked!

Do you advise leaving the changed settings as-is, or do you think it is best for me to revert to the former settings?

 
Avatar Beltrán Rueda Administrator 3,714 post(s)

Hi,

It is ok now, this configuration allow to upload large files to the application or write in the database. it is not necessary to revert the changes.

Forums SugarCRM