This forum is no longer active. Please post your questions to our new community site

Forums Trac

problem doing update after plugin install

Subscribe to problem doing update after plugin install 3 post(s), 2 voice(s)

 
Avatar raveenb 3 post(s)

Hi,
Firstly, great work, you guys! Installed latest Bitnami Trac stack on Mac OS X Snow Leopard today

Then figured out the long way to install plugins into the trac, then when i enabled them, trac wanted to do an upgrade of the installation and when i did, I got an error(see below) any ideas on how to get it running again,

BTW, i am running this command after i ran the use_trac command which came with the installation, guess it out the the correct python and the trac binaries in the path.

bash-3.2$ trac-admin /Applications/trac-0.11.6-1/projects/RaTrac/ upgrade
/Applications/trac-0.11.6-1/trac/bin/trac-admin: line 3: requires: command not found
/Applications/trac-0.11.6-1/trac/bin/trac-admin: line 4: import: command not found
/Applications/trac-0.11.6-1/trac/bin/trac-admin: line 7: syntax error near unexpected token `newline’
/Applications/trac-0.11.6-1/trac/bin/trac-admin: line 7: `sys.exit(’

 
Avatar raveenb 3 post(s)

i found a way around this problem. I used the autoupdate plugin from trac-hacks and it worked without any problems. although the authors of this plugin claim it to be dirt hack, but it worked for me.

 
Avatar Beltrán Rueda Administrator 3,714 post(s)

I’m glad to hear this.

Forums Trac