This forum is no longer active. Please post your questions to our new community site

Forums Tracks

Issue with Track backup

Subscribe to Issue with Track backup 10 post(s), 2 voice(s)

Avatar mzhulaev 8 post(s)

Hi folks,

I have a problem with the backup of my Tracks DB.

I tried to follow the instructions on but faced the problem.

I copied the whole directory of Stack out of disk “C” and re-installed Windows.

After I put the directory back in “Program files” and tried to launch “serviceinstall.bat Install”. It seemed to work fine and all the services were launched (checked through system management).

When I try to connect to stack via browser I got “500 internal error”.

I tried to work around and found out that the problem could be MySQL. It couldn’t allocate db tables:
1. I manually connected to it through “mysql -u root -p”
2. Then chose “use bitnami_tracks” as a main database.
3. Try “show tables” and saw all the tables required (tags, contexts etc)
4. However when I try to select any table (i.e. “select * from tags”) it reports an error “ERROR 1146 (42S02): Table ‘bitnami_tracks.tags’ doesn’t exist”

Here is the error description from the MySQL log file:
“[ERROR] Cannot find table bitnami_tracks/tags from the internal data dictionary
of InnoDB though the .frm file for the table exists. Maybe you
have deleted and recreated InnoDB data files but have forgotten
to delete the corresponding .frm files of InnoDB tables, or you
have moved .frm files to another database?
See ”">…
how you can resolve the problem."

The same problem appear if I try to use “mysqldump”:
mysqldump -u root -p -P 3345 bitnami_tracks > backup.sql
Enter password: ********
mysqldump: Got error: 1146: Table ‘bitnami_tracks.contexts’ doesn’t exist when using LOCK TABLES

Characteristics of my installation:
1. I have NOT standard ports for apache & MySQL (90 and 3345 correspondingly)
2. The name of the directory is the same, however it is shorten to “C:\PROGRA~1\BITNAM~2”, cause I have several bitnami products installed. I verified that it referred to the right folder.

It would be nice if anyone can help me with this issue.
Thanks in advance.

Avatar Beltrán Rueda Administrator 3,714 post(s)


Are you copying the directory in the same location right? Could you check if the mysql/data/bitnami_tracks/*.frm files exist?

Avatar mzhulaev 8 post(s)

Hi beltran

1. I think I copy it right :) cause in my case this process has 2 steps:
1.1 Create folder name like “BitNami Tracks 1 Stack” to have “C:\PROGRA~1\BITNAM~1"
1.2 Copy folder “BitNami Tracks Stack” from Disk D to have “C:\PROGRA~1\BITNAM~2". This folder is a rar archive, which is the previous installation.

2. All this files exist and are not null, i.e. the size is about 8-9 kBytes

I forgot to mention that I can manually check system db, named “information_schema”, and make select of any tables of this schema

Avatar mzhulaev 8 post(s)

Oh yeah :) one more detail

I probably forgot to stop the services before create a copy of stack folder. May be it didn’t finalize DB correctly?

Avatar Beltrán Rueda Administrator 3,714 post(s)

Yes that was the problem, you should stop the database before copying it. Can you start the backup process one more time or you can not access to the original installation? I’m sure there are ways to recover the database.

Avatar mzhulaev 8 post(s)

The problem is that I formated disk C.
So, all I have is the copy of Stack folder with NOT stopped DB. And I can’t start it again because of the problem described above (

I am pretty sure that it is possible to handle somehow, but I don’t know how exactly )

Avatar Beltrán Rueda Administrator 3,714 post(s)

Maybe this could help you:…

“If MySQL crashes in the middle of an ALTER TABLE operation, you may end up with an orphaned temporary table inside the InnoDB tablespace. Using the Table Monitor, you can see listed a table with a name that begins with #sql-. You can perform SQL statements on tables whose name contains the character “#” if you enclose the name within backticks. Thus, you can drop such an orphaned table like any other orphaned table using the method described earlier.”

Avatar mzhulaev 8 post(s)

ok, thanks. Give me 10 mins to try

Avatar mzhulaev 8 post(s)

I tried these solutions, but with no results.

I am trying googling on “InnoDB table corrupt”. May be u can help a bit, cause I am not experinced in MySQL?

Avatar mzhulaev 8 post(s)

Hi again

I investigated ab. 3 hours to solve this problem, tried about 10 solutions but unsuccessfully (

I found one program. Here the link:…
But it is for Linux OS

So, I am stopping any attempts to fix innoDB index. It seems not possible to do this way (

However, I found an old recovery of my data but in form of YML file. Can u help me with it? Is it easy to parse or convert to SQL data?

Forums Tracks