This forum is no longer active. Please post your questions to our new community site

bitnami-djangostack-1.2.5-0-ubuntu-10.10

Subscribe to bitnami-djangostack-1.2.5-0-ubuntu-10.10 3 post(s), 2 voice(s)

 
Avatar andrey.lartsev 2 post(s)

Hi Guys,
I have found two major problems with this VA.
1) the Python’s “easy_install” don’t work because an error in the first script’s line. This is located in /opt/bitnami/python/bin/easy_install
Need to changes it to remove superflous /usr/bin/env. Now it looks like:
#!/usr/bin/env /usr/bin/env /opt/bitnami/python/bin/python2.6

2) The second problem is strongly related to the first one :-) The apt-get command tends to install an another instance of python if you try to install any python module with it. For example the following command would install second instance of python and django in addition to exiting ones in /opt/bitnami
$ sudo apt-get install python-django-south

 
Avatar Beltrán Rueda Administrator 3,714 post(s)

Hi,

Thanks for your feedback. You are right, we will fix the double “/usr/bin/env” in easy_install script.

BitNami Stacks are self-cointaned and independent of the system, to install any django module you can download the egg file and install it using easy_install.

Cheers.

 
Avatar Beltrán Rueda Administrator 3,714 post(s)

Fixed in DjangoStack 1.3 version.