This forum is no longer active. Please post your questions to our new community site

OCPortal VM - Access Errors (Edit)

Subscribe to OCPortal VM - Access Errors (Edit) 5 post(s), 2 voice(s)

Avatar Samurai Jack 3 post(s)


I am testing out the latest OCPortal “virtual machine” from bitnami (ocPortal 7.0.1-0 VMware, openSUSE 11.3).

It is running on our VM server.
We updated some files on the VM to access phpMyAdmin from other machines.
We can successfully login to phpMyAdmin.

We tried accessing ocportal, there are various error messages about not having proper access. The pages do not display properly. Access to the “admin zone” is also not possible (with an admin account no less).

I was wondering if this could be caused by not setting file permissions with chmod ? Or maybe a problem with MySQL ?

If anyone knows how to fix this, please let me know.

(Don’t know how to include images in bitnami post)

my ocportal forum link (with image):…

Avatar Beltrán Rueda Administrator 3,714 post(s)

Is it possible that you modified the IP or DNS of the machine? Try to reboot the machine or run the following command:

$ sudo /opt/bitnami/updateip —machine-hostname NEW_IP_OR_DOMAIN

I hope it helps.

Avatar Samurai Jack 3 post(s)

There is a possibility you need to update or fix the ocportal vm. OCPortal staff suggests:

“This can happen if the Comcode pages are marked as owned by Guest. We used to have them like this in older versions, but it was changed — they [Bitnami] may not have created the package via running an ocPortal upgrade and not correcting the problem before repackaging. Emptying the comcode_pages and cached_comcode_pages tables should fix it. "

I followed this advice and deleted the entries in those database tables. That got the site working properly. However, the site can’t display RSS news feeds or internet based content due to some kind of network connection error. I don’t know if that is due to config file settings on the VM or if its a misconfigured OCPortal setting. Any advice you can give is helpful. Thanks.

I also noticed that when I ran the ocportal upgrader (http://myip/ocportal/upgrader.php), the mysql data table needed to be upgraded from 6 to 7. There may have been some missed update / maintnence work. Please fix the VM and contact Chris Graham (Managing Director) @ to solve any problems.


Avatar Beltrán Rueda Administrator 3,714 post(s)

Thanks for reporting it. We are checking if there is something to fix in the configuration.

Avatar Beltrán Rueda Administrator 3,714 post(s)

Fixed in th 7.1.0 version! Thanks.