This forum is no longer active. Please post your questions to our new community site

ubuntu sugarcrm and virtualbox

Subscribe to ubuntu sugarcrm and virtualbox 7 post(s), 5 voice(s)

Avatar arnab74 15 post(s)

When I use ubuntu sugarcrm vm with vmplayer it is working, but when I try it on virtualbox, it says :
This kernel requires the following features not present in the cpu:pae
Unable to boot-Please use a kernel appropriate to your cpu.


Avatar Beltrán Rueda Administrator 3,714 post(s)


Please check the Virtual Appliance settings. Try to enable PAE in the System → Processor → Extended Feature.


Avatar arnab74 15 post(s)

Beltran hi,
Thanks for the reply. Your solution helped but I got stuck in the same problem as written in “virtualbox-install-to-usb-flash-drive”.
I edited the /boot/grub/menu.lst and added rootdelay=30 but it has not helped.
Any other suggestions….

Avatar danoo Administrator 81 post(s)

Have you been able to figure out what the problem is ?

Avatar patrickj 2 post(s)

I posted on another thread, but hey – here I go again. Try moving the disk from the virtual SATA to the virtual IDE bus. That worked for me with the joomla 1.5 on ubuntu 10.4 appliance.

Avatar mhenke 13 post(s)…


To fix I did the following (Older VirtualBox Versions):

Shutdown the VM.
Open the settings on the VM through the Sun xVM VirtualBox manager
General → Advanced → check Enable PAE/NX
Start your VM
Newer Virtual Box Versions:

Shutdown the VM.
Open the settings on the VM.
System → Processor → check Enable PAE/NX
Alternatively, with Ubuntu, you should be running the virtual kernel. Install server as normal, then before rebooting hit alt-f2 to get a shell. Run “chroot /target”. Then “apt-get install linux-virtual”. You could also do the same by booting for the install CD and selecting the option to repair the install and running apt-get from there.Enjoy :)

Avatar Beltrán Rueda Administrator 3,714 post(s)

Right, thanks for posting it. We have updated the documentation to enable PAE