This forum is no longer active. Please post your questions to our new community site

Unable to access VM joomla from another computer

Subscribe to Unable to access VM joomla from another computer 3 post(s), 2 voice(s)

Avatar Chris S 2 post(s)


I installed the Joomla SUSE VM stack on VMware got it running no problem. I was able to access the product from the same machine no problem. I tried to access it via IP from another machine using the bridge DHCP address. The bitnami webpage launched for a split second then i got a connection reset browser error.

I thought my Vmware implementation was messed up so I configured it all using Virtualbox — same efffect.

I then thought OK maybe it is some firewall setting on my machine OS X 10.6.6

I fired it up on another machine also running 10.6.6 and got the same result. Again the vm is accessible from the machine it is installed on but not from another machine on the network.

The VM is pingable, but SSH and web access both get reset.

I reset the vm networking to NAT and then back to bridge again but that did not help.

All Mac OSX firewalls have been disbaled.

I got the same result from the SUSE Wordpress VM as well.

Any thoughts?

Avatar Chris S 2 post(s)

Well I feel a little dumb as I solved my own problem. In a quirk of silly network design and various places around the house of low WIFI signal strength both macs in question are using Internet Connection Sharing in order to provide other devices access to the internet. It turns out that this service (built-in to Mac OS X) seems to interfere with web traffic passing through to the Virtual Machines hosted by VMware and Vitualbox — this tells me that it is a limitation of the Mac’s networking stack, but I have not verified this in depth yet nor figured out exactly what the cause is.

So in closing if anybody has this quirky problem and happens to have Internet Connection Sharing turned on on in OS X 10.6.x then disable it and you should be good to go.

This does not seem to be confined to Bitnami images as I also experienced the same problem from a newly installed Windows Server 2008 VM on vmware fusion.

Avatar Beltrán Rueda Administrator 3,714 post(s)

I’m glad to hear that you solved the problem. Thanks for posting the solution too :)