This forum is no longer active. Please post your questions to our new community site

Forums WAMPStack

Is there a silent switch to install Wamp ?

Subscribe to Is there a silent switch to install Wamp ? 8 post(s), 2 voice(s)

 
Avatar nimi 4 post(s)

Hi,
I would like to install bitnami-wampstack-1.2-3-windows-installer.exe silently,

is there a silent switch or any swithes at all ?

 
Avatar Beltrán Rueda Administrator 3,714 post(s)

Hi,

Yes, try to run the installer from a command prompt. With the “—help” option you can see the options that you can use. You can install it silently using “—mode unattended” option.

 
Avatar nimi 4 post(s)

Hi beltran,
Thank you for your help, unfortunately I didn’t succeded.
With the “—help” option , I got this :
Error in TclKit
Command-specific options:
colormap: Colormap for main window
-display: Display to use
-geometry: Initial geometry for window
-name: Name to use for application
-sync: Use synchronous mode for display server
-visual: Visual for main window
-use: Id of window in which to embed application
-
: Pass all remaining arguments through to script
And using “—mode unattended” I got this error message :
Error
There has been an error.
Expected option but got “?mode”. Options start with a leading “—” prefix
Use -help to get a list of valid options
I also tried with :
“—unattended”
As the Error messge is unclear to me.
I got this error message :
Error
There has been an error.
Expected option but got “?unattended”. Options start with a leading "
-" prefix
Use —help to get a list of valid options
(I don’t know why it is underlined and how to fix it . . .)

 
Avatar Beltrán Rueda Administrator 3,714 post(s)

Hi, try with two dashes.

 
Avatar nimi 4 post(s)

Perfect, it worked :
- -mode unattended

Now, I can’t login . . .
Sorry, I used what I found in – -help :

- -base_user Login
Default: user
- -base_password Password
Default:

- -mysql_database_username DB User Name
Default: mysql_user
- -mysql_database_password DB User Password
Default:

- -phpmyadmin_password Password
Default:

I tried them all to login in phpmyadmin.
By default, there is no password.
That’s maybe why one can’t login.
What shall have I done instead ?

 
Avatar Beltrán Rueda Administrator 3,714 post(s)

Hi,

It is necessary to specify the “base_password” option and this password should be equals or greater than 4 characters.

 
Avatar nimi 4 post(s)

Thank you beltran,

Everything works now.

I summarize for it could be of some help to any user :

I made a silent install in a console window, like this :
Caution there is 2 dash – -, but it looks like there is only one.

installer path /bitnami-wampstack-1.2-3-windows-installer.exe —mode unattended —base_password “your choosed password here”

In this bitnami-wampstack-1.2-3-windows-installer.exe version of the file, there is already a default user.

So to login in phpMyAdmin page you need to input administrator and the password you choosed above.

 
Avatar Beltrán Rueda Administrator 3,714 post(s)

Thanks for posting the summary, this will help to other users.

Forums WAMPStack