This forum is no longer active. Please post your questions to our new community site

Forums WAPPStack

error during installation!!!

Subscribe to error during installation!!! 31 post(s), 12 voice(s)

Pages: « Previous 1

 
Avatar elias86 1 post

Hello everybody! I get this error during bitnami install:

Error running D:\programmi\../psql.exe – U postgres -p 5432 -h localhost -c "alter user postgres password ‘******’: psql: could not connect to server: Connection refused (0×0000274d/10061) Is the server running on host “localhost” and accepting TCP/IP connections on port 5432? The application will exit now.

Who can help me???? :)

 
Avatar Beltrán Rueda Administrator 3,714 post(s)

Hi,

Do you have any firewall enabled? Could you disabled it?

 
Avatar dz1300 1 post

I have the same problem.
My OS is windows VISTA Service Pack 2, and i run bitnami-wappstack-1.2-1-windows-installer.exe with a administrator user.
I have turned all my firewall and anti-virus software off.

The message is:
There has been an error.
Error running C:\Program Files\BitNami
WAPPStack1.2.1/postgresql/bin/psql.exe -U postgres -p 5432 -h
localhost -c "ALTER USER postgres PASSWORD ‘********’ : psql
could not connect to server: Connection refused
(0×0000274D/10061)
Is the server running on host “localhost” and accepting
TCP/IP connections on port 5432??
could not connect to server: Connection refused.

I run netstat -a -p tcp in CMD but can not find a LISTENING 5423 TCP port.
and i run postgres.exe in c:\Program Files\BitNami WAPPStack1.2.1\postgresql\bin but postgresql still can not start. a message said:
Execution of PostgreSQL by a user with administrative permissions is not
permitted.
The server must be started under an unprivileged user ID to prevent
possible system security compromises. See the documentation for
more information on how to properly start the server.

So i try to install WAPPStack with a normal user acconts again but the installation hangs in the middle.

 
Avatar terranghost 1 post

I’m having the same problem. I’m using win xp. tried disabling firewalls, antivirus, using win2k compatibility mode, nothing works.

 
Avatar Beltrán Rueda Administrator 3,714 post(s)

Hi,

Sorry we can not reproduce on our side, Could you try to install in a different machine?

 
Avatar zhjliu 4 post(s)

I met the same error when installing, and I try on defferent computer with windows XP system, but the error also appear again.

who can help me?

 
Avatar zhjliu 4 post(s)

The same error occurs when i try to install WAPPStack 1.2.0 as well as WAPPStack 1.2.1.

Error running C:\Program Files\BitNami
WAPPStack1.2.1/postgresql/bin/psql.exe -U postgres -p 5432 -h
localhost -c "ALTER USER postgres PASSWORD ‘********’ : psql
could not connect to server: Connection refused
(0×0000274D/10061)
Is the server running on host “localhost” and accepting
TCP/IP connections on port 5432??
could not connect to server: Connection refused.
The application will exit now.

 
Avatar zhjliu 4 post(s)

I made another attempt, first I installed the WAMP and succeeded without any error, then I installed the WAMP-postgresql-addon and met the same error as above:
the message is:
There has been an error.
Error running C:\BitNami WAMPStack/postgresql/bin/psql.exe -U postgres -p 5432 -h localhost -c “ALTER USER postgres PASSWORD*’”: psql:
Is the server running on host “localhost” and accepting
TCP/IP connections on port 5432?
The application will exit now.

What does this mean? How can I solve it?

 
Avatar zhjliu 4 post(s)

This error occurs at every time when waiting for Postmaster.

 
Avatar Beltrán Rueda Administrator 3,714 post(s)

Hi,

Are you using a Windows domain? Could you remove the postgres user and try again? Please take a look the following posts:

http://forums.enterprisedb.com/posts/list/1896….
http://forums.enterprisedb.com/posts/list/2044….

Regards

 
Avatar jyc9999 1 post

I got the same exact error when I was installing it. Newly installed XP machine here. I disabled firewall and anti-virus. The machine has nothiing but the new XP professional SP3.

I followed the two links, it didn;t help me either.
 
Avatar Beltrán Rueda Administrator 3,714 post(s)

Hi,

Could you check if the hosts file contains the “localhost” line?

C:\Windows\System32\drivers\etc\hosts

localhost 127.0.0.1

 
Avatar dami 2 post(s)

I, too, am having this problem. I have disabled firewall, turned off virus scanner, hosts file has the localhost line uncommented. I’m on Windows7. HELP!

Thanks,
Dami

 
Avatar Beltrán Rueda Administrator 3,714 post(s)

Hi,

Could you check the following?

- Check if the services wappPostgreSQL or wappPostgreSQL-1 are running. Is there any content in the /postgresql/data folder?
- Remove the services with “sc delete wappPostgreSQL” from a command prompt as Administrator
- Try to install again
- When the error occurs try to execute from the command prompt as administrator:
- If the content of the data folder is empty execute:

\postgresql\bin\initdb.exe -U postgres -E UTF8 -D “/postgresql/data”

- In the data/postgresql.conf enable log_destination, log_directory and set logging_collector = on
- If the service shopkeepPostgreSQL is not started execute:

cd \postgresql\bin
pg_ctl.exe start -D ../data

 
Avatar dami 2 post(s)

1. wappPostgreSQL, 1,2, 3 are listed but all three are stopped. There is no content in the data folder.
2. I get [SC] OpenService FAILED 1060: The specified service does not exist as an installed service.

 
Avatar przno 1 post

hi,
did you solve this problem? i am having same problem on win7, i closed all applications, disabled firewall, but still it stopy in the middle of instalation with the same error. services are there, but stopped and cannot be deleted.

 
Avatar shuaixf 3 post(s)

I turned off the firewall and met the same problem when installing wappstack 1.2.2 or 1.2.3 on win7.

Could you help me? Thanks!

 
Avatar Beltrán Rueda Administrator 3,714 post(s)

Hi,

Could you give us access to try to see what is happening? You can contact with us at hello (at) bitnami (dot) org.

 
Avatar ubiwire 1 post

i had resoved this problem :because postgresql/data is empty

step1 :
when you first time install wappstack, you get error because postgresql/data is empty ,

you must manully get the content of directory postgresql/data, by the following command line:

bq.(initdb.exe -U postgres —locale=C -E UTF8 -D /postgresql/data)

you can also download from attachement ..

step 2:
delete the old install directory , reinstall wappstack,before you be in process of wait for postmaster.

you copy the content of the dirctory postgresql/data(you get from step 1) into the new install directory ,/postgresql/data,

this is all..you will install wappstack suceessully

 
Avatar Beltrán Rueda Administrator 3,714 post(s)

Hi,

Thanks for posting it. We have investigated this issue and it will be fixed in the next release. Cheers.

 
Avatar rbauer 5 post(s)

Sorry, when the next release (my school’s project is getting impatient :-) )?

Many thanks.

 
Avatar Beltrán Rueda Administrator 3,714 post(s)

Hi, if all our tests goes well we will release a new version this week. Cheers.

 
Avatar emmie 3 post(s)

also having a BIG problem here :(

i can’t install successfully the bitnami-wappstack-1.2-5-windows-installer in my pc, but when i tried it on my friend’s pc, it worked. she has windows xp and enabled firewall.

i have windows 7 and i also tried installing it as a domain user and disabling the firewall but still, it was also a failure.

and i always get the same error:

Error running C:\Program Files\BitNami\WAPPStack/postgresql/bin/psql.exe -U postgres -p 5432 -h localhost -c “ALTER USER postgres PASSWIRD ‘****’”: psql: could not translate host name “localhost” to address: Unknown server error

this always happens after the installation process comes to this point: Waiting for Postmaster

and the application will then exit.

i wonder if the error is on the postgresql. because when i tried installing postgresql-9.0.4-1-windows, there was also an error and i was prompted to check C:\Users\Emachines\AppData\Local\Temp for the installation log in. and when i launched pgAdminIII, error again says:

Error connecting to the server: could not translate host name “localhost” to address: Unknown server error

another thing, i tried installing WAMPStack with bitnami-wampstack-1.2-5-windows-installer, and it was successful.

but unfortunately, our professor required us to use WAPPStack.

PLEASE.. CAN SOMEONE HELP ME? :(

 
Avatar Beltrán Rueda Administrator 3,714 post(s)

Could you try to install the PostgreSQL module add-on on top of WAMP Stack? This installs PostgreSQL and phpPGAdmin on top of WAMP Stack.

 
Avatar emmie 3 post(s)

i did what you have just said but it made no difference…
waiting for postmaster.. and this message again:
Error running C:\Program Files\BitNami\WAPPStack/postgresql/bin/psql.exe -U postgres -p 5432 -h localhost -c “ALTER USER postgres PASSWORD ‘****’”: psql: could not translate host name “localhost” to address: Unknown server error

oh, by the way, when i uninstalled the postgresql-9.0.4-1-windows, the postgresql data directory was not removed. i was prompted to restart my pc. i did so and deleted the data directory afterwards. has that something to do with the error?

sorry for sounding so naive. i really need some help here :(

 
Avatar Beltrán Rueda Administrator 3,714 post(s)

Hi,

Is a 64 bits Windows system? Could you try to install the following and then reinstall the Stack? http://www.microsoft.com/downloads/en/details.a…

 
Avatar emmie 3 post(s)

i can’t install it. rather, i got this one..
This setup program requires an x64 platform. It cannot be installed on this platform.

 
Avatar Beltrán Rueda Administrator 3,714 post(s)

Not sure waht could be the exact problem. Could you post the log file to check what could be the exact error?

1. Open a “command prompt” as Administrator
2. Type the following:

> cd TEMP
> explorer .

3. Order by date and attach the latest bitrock_installer_XXXX.log file

Cheers.

 
Avatar shuaixf 3 post(s)

[00:54:12] cacls “D:\WAPP/postgresql/data” /e /c /t /p shuaixf:c"
[00:54:12] postgres_grantedPermissions = delete file_append_data file_execute file_generic_execute file_generic_read file_generic_write file_read_attributes file_read_data file_read_ea file_write_attributes file_write_data file_write_ea read_control standard_rights_execute standard_rights_read standard_rights_write synchronize
[00:54:12] postgres_deniedPermissions =
[00:54:12] Running setWindowsACL
[00:54:12] postgres_grantedPermissions = delete file_append_data file_execute file_generic_execute file_generic_read file_generic_write file_read_attributes file_read_data file_read_ea file_write_attributes file_write_data file_write_ea read_control standard_rights_execute standard_rights_read standard_rights_write synchronize
[00:54:12] postgres_deniedPermissions =
[00:54:12] Initializing database
Executing initdb.exe -U postgres -E UTF8 -D D:/WAPP/POSTGR~1/data
Script exit code: 1

Script output:

Script stderr:
Program ended with an error exit code

Error running initdb.exe -U postgres -E UTF8 -D D:/WAPP/POSTGR~1/data : Program ended with an error exit code
Executing sc stop
Script exit code: 1639

 
Avatar shuaixf 3 post(s)

XP

Script stderr:
Program ended with an error exit code

Error running cmd /C net accounts /domain : Program ended with an error exit code
[00:22:57] net accounts /domain: Program ended with an error exit code
[00:22:57] Creating C:\Program Files\BitNami WAPPStack/postgresql/data
[00:22:57] C:\Program Files\BitNami WAPPStack/postgresql/data OK
[00:22:57] Before running cacls
[00:22:58] postgres_grantedPermissions = delete file_all_access file_append_data file_delete_child file_execute file_generic_execute file_generic_read file_generic_write file_read_attributes file_read_data file_read_ea file_write_attributes file_write_data file_write_ea read_control standard_rights_all standard_rights_execute standard_rights_read standard_rights_required standard_rights_write synchronize write_dac write_owner
[00:22:58] postgres_deniedPermissions =
[00:22:58] Running cacls
Executing cacls “C:\Program Files\BitNami WAPPStack/postgresql/data” /e /c /t /p Administrator:c
Script exit code: 0

Script output:
processed dir: C:\Program Files\BitNami WAPPStack\postgresql\data

Script stderr:

[00:22:58] cacls “C:\Program Files\BitNami WAPPStack/postgresql/data” /e /c /t /p Administrator:c"
[00:22:59] postgres_grantedPermissions = delete file_append_data file_execute file_generic_execute file_generic_read file_generic_write file_read_attributes file_read_data file_read_ea file_write_attributes file_write_data file_write_ea read_control standard_rights_execute standard_rights_read standard_rights_write synchronize
[00:22:59] postgres_deniedPermissions =
[00:22:59] Running setWindowsACL
[00:22:59] postgres_grantedPermissions = delete file_append_data file_execute file_generic_execute file_generic_read file_generic_write file_read_attributes file_read_data file_read_ea file_write_attributes file_write_data file_write_ea read_control standard_rights_execute standard_rights_read standard_rights_write synchronize
[00:22:59] postgres_deniedPermissions =
[00:22:59] Initializing database
Executing initdb.exe -U postgres -E UTF8 -D C:/PROGRA~1/BITNAM~1/POSTGR~1/data
Script exit code: 1

Script output:

Script stderr:
Program ended with an error exit code

Error running initdb.exe -U postgres -E UTF8 -D C:/PROGRA~1/BITNAM~1/POSTGR~1/data : Program ended with an error exit code
Executing sc stop
Script exit code: 0

Script output:
DESCRIPTION:
Sends a STOP control request to a service.
USAGE:
sc stop [service name]

Script stderr:

Executing sc delete
Script exit code: 0

Script output:
DESCRIPTION:
Deletes a service entry from the registry.
If the service is running, or another process has an
open handle to the service, the service is simply marked
for deletion.
USAGE:
sc delete [service name]

Script stderr:

Next Page

Pages: « Previous 1

Forums WAPPStack