This forum is no longer active. Please post your questions to our new community site

Forums WAPPStack

[Solved] New to WAPPStack, some questions

Subscribe to [Solved] New to WAPPStack, some questions 7 post(s), 3 voice(s)

 
Avatar Onox 4 post(s)

Hi,

First, I thank you BitNami because I wanted to try PostgreSQL without having to do a manual install :) I am not really a newbie to the SQL language because I already have some experience with MySQL (I use wampserver as WAMP distribution), but there are a couple of things I would like to know specifically about WAPPStack :

1) When I logout from phpPgAdmin, the wappstackApache and wappstackPostgreSQL services keep running… The “Stop BitNami WAPPStack service” shortcut in the start menu folder does not stop them either. I don’t want to open Task Manager to start/stop these services everytime, and I think it could conflict with the wampapache and wampmysqld services… what am I doing wrong ?

2) I am reading the beginning of the tutorial on PostgreSQL in the official documentation, chapter 1.3. But I cannot create a database with command line because I am asked a password… and when I type my password : “createdb : could not connect to database postgres : FATAL : authentication failed for user <my operating system username in the>...

I tried a) the password I chose when installing WAPPStack and b) the password of my Windows account, and neither of them works. What am I supposed to do ?

Thanks

 
Avatar Beltrán Rueda Administrator 3,714 post(s)

Hi,

Are you running WAPP on Vista? In this case you should execute the shortcut with “administrative” privileges to stop the services. Try to clicck using the right button in the “Stop services” shortcut and then select “run as administrator”. This should stop the services.

About your second question, the ser that you should to use is “postgres” and the password is the same that you chose during the installation.

> psql -U postgres

Cheers.

 
Avatar Onox 4 post(s)

Thanks for these answers. Yes, I use Vista and by running the shortcuts with administrative privileges it works :)

About the second question, I can connect with psql -U postgres and my password. But then I still don’t seem to be able to create a database :

If I type : createdb my_base
and then
psql my_base : nothing.
\c my_base : FATAL : database ” my_base ” does not exist ?

 
Avatar Beltrán Rueda Administrator 3,714 post(s)

Hi,

I have used these commands to create a database:

1. Go to Start Menu and “Use BitNami WAPPStack” shortcut
2. Type:

> psql -U postgres
postgres# create database mydatabase;

3. Other option is to use createdb command:

> createdb -U postgres mydatabase2

You can also create your database from the phppgadmin panel at http://127.0.0.1/phppgadmin.

I hope it helps.

 
Avatar Onox 4 post(s)

Thanks a lot for the help beltran. =)

Unfortunately, it still doesn’t work. Confusing… Not really a problem for now, since there is phpPgAdmin, but… Maybe I should ask on the posgresql.org forums ?

 
Avatar Onox 4 post(s)

Ok now it works… I went on the postgresqlfr IRC Channel, and they made me understand that I was confusing the shell command createdb with the psql shell that only accepts SQL commands.

 
Avatar mhartman 9 post(s)

You might find pgAdmin (http://www.pgadmin.org/) better than phpPgAdmin if you’re using the stack on a local machine.

Forums WAPPStack