This forum is no longer active. Please post your questions to our new community site

Forums WordPress

Changing URL & Port Number - WordPress Mac OS X PPC Stack

Subscribe to Changing URL & Port Number - WordPress Mac OS X PPC Stack 20 post(s), 2 voice(s)

 
Avatar wordweaver 10 post(s)

Hello. First of all, allow me to offer a thank-you to the people who are behind the Bitnami WordPress stack for Mac OS X. You have saved me a lot of time, work and hassle . . . and I am almost where I want to be with my installation, which you can currently see at the following URL:

http://www.endtimeprophecy.net:8080/wordpress/

While my primary domain — as well as my WordPress blog — have now been migrated from my current server over to your Bitnami stack, there are still two important things which I need to change, but I don’t know how to do it, being as I have zero experience with running an Apache server.

I have been running my various domains — and since January, a WordPress blog — on a ten-year-old Macintsoh G4 mini-tower running Mac OS X Tiger 10.4.11 with the WebSTAR server suite from 4D.

Everything was fine until a few days ago when I upgraded to WordPress 3.2 and was presented with the message that it required at least PHP 5.2.4.

Without going into all of the details regarding why I couldn’t just update my current PHP installation, yesterday I discovered the PPC version of your Bitnami WordPress stack for Mac OS X, which I have successfully installed on my Macintosh G4 mini-tower running Tiger 10.4.11 PPC.

I have also successfully imported all of my posts, comments, menus, plug-ins, etc., from my current WordPress blog on my WebSTAR server.

The biggest remaining problem appears to be the URL path.

Our primary website — Endtime Prophecy Net — has been located at . . .

http://www.endtimeprophecy.net

. . . for eleven years. It is well-established at that URL.

Furthermore, our WordPress blog is well-established at . . .

http://www.endtimeprophecy.net/Blog/

. . . as well.

When I say “well-established”, I mean that these two URL’s are used in hundreds of topsites lists and link directories, in thousands of Google SERP’s and in other search engines, on social networking sites, etc.

That is why it is imperative that I be able to continue to use these two URL’s. To have to suddenly change the URL’s would destroy our online presence, and we would probably suffer in our Google PageRank, Alexa Traffic Rank, etc. as well, and lose lots of visitors until we rebuild our presence, which has taken years to establish.

However, upon using the Bitnami stack, I am forced to use this . . .

http://www.endtimeprophecy.net:8080/

. . . for our home page

and this . . .

http://www.endtimeprophecy.net:8080/wordpress/

for our blog home page.

This will not do, and I cannot go public with our new setup until . . .

http://www.endtimeprophecy.net:8080/

becomes just . . .

http://www.endtimeprophecy.net/

again, and . . .

http://www.endtimeprophecy.net:8080/wordpress/

. . . becomes just . . .

http://www.endtimeprophecy.net/Blog/

again.

As I said, I have no experience with Apache. However, I opened the “httpd.conf” file in “apache2/conf/” and edited lines 40 and 155 so that they say . . .

line 40 : Listen 80
line 155 : ServerName localhost:80

However, when I do that, while the mySQL server will start in the manager app, the Apache server refuses to start unless I switch both port numbers back to 8080.

Even if I shut down WebSTAR — which uses port 80 — and reboot the machine, I still can’t get the Apache server to start on port 80 after editing the “httd.conf” file.

Likewise, if I go into “WordPress/apps/” and change the “wordpress” folder name to “Blog”, I get 404 errors. I imagine that editing the three path lines in “WordPress/apps/wordpress/conf/” so that they say “Blog” instead of “wordpress” wouldn’t help either.

So, if someone can assist me in making these two important URL changes, so that they are site-wide, I would be most appreciative, and could then go public . . . well, after I figure out how to set up virtual hosts for the other three domains that I run.

Two final questions:

1. When new versions of WordPress are released, will I still be able to update my current version automatically, or manually, as I have been doing, or will I need to wait for you to release a new Bitnami stack?

2. The same applies to Apache, mySQL and PHP. Since updates by developers are geared towards updating software that is built into the OS, would I have to wait for you to release a new stack in order to take advantage of any new versions of these software?

Thanks so much for any assistance which you can offer. Again, please understand that I am not familiar with Apache, so if you can assist, please take the step-by-step dummy approach, and assume that I don’t understand.

Thanks!

 
Avatar Beltrán Rueda Administrator 3,714 post(s)

Hi,

To run your Wordpress in http://YOUR_URL/ on OS X it is necessary to install the Stack as root user, because regualr users can not use the 80 port. You can install the Stack from a Terminal:

$ sudo ./bitnami-wordpress*/Contents/MacOS/installbuilder.sh

Then you can also add the Blog in the URL http://YOUR_URL/Blog. Take a look this guide http://wiki.bitnami.com/Applications/BitNami_Wo…

When new versions of WordPress are released, will I still be able to update my current version automatically

Yes, you can upgrade wordpress from the Administrator panel

2. The same applies to Apache, mySQL and PHP. Since updates by developers are geared towards updating software that is built into the OS, would I have to wait for you to release a new stack in order to take advantage of any new versions of these software?

We try to have most of the components and applications up-to-date so you do not need to wait a lot of time :)

 
Avatar wordweaver 10 post(s)

Hello Beltrán. Thank-you for your response.

I just followed your instructions using the Terminal to install the stack as root, and it did indeed select port 80 for Apache, instead of port 8080, so that I can now access the website’s root folder at http://www.endtimeprophecy.net, instead of at http://www.endtimeprophecy.net:8080.

I just read the instructions at the other URL, and I am still having difficulty understanding how to set the path for the blog to http://www.endtimeprophecy.net/Blog/.

In other words, I don’t want to change the root folder for our main site. I want to keep it as “htdocs”, as it now is. What I want to do — as I currently do with my WebSTAR server — is access the blog from a folder inside my main site, that is named “Blog”. That is how my WebSTAR server is set up.

I went to:

apps/wordpress/conf/

and changed this:

Alias /wordpress/ “/Applications/WordPress/apps/wordpress/htdocs/”
Alias /wordpress “/Applications/WordPress/apps/wordpress/htdocs”

<Directory “/Applications/WordPress/apps/wordpress/htdocs”>
Options Indexes MultiViews +FollowSymLinks
AllowOverride All
Order allow,deny
Allow from all

To this:

Alias /wordpress/ “/Applications/WordPress/apps/Blog/htdocs/”
Alias /wordpress “/Applications/WordPress/apps/Blog/htdocs”

<Directory “/Applications/WordPress/apps/Blog/htdocs”>
Options Indexes MultiViews +FollowSymLinks
AllowOverride All
Order allow,deny
Allow from all

I then changed “apps/wordpress/” to “apps/Blog/” in the actual “apps” directory, but it did not work.

So how can I use “http://www.endtimeprophecy.net/Blog/”?

Thanks for your patience. I am learning, but it is difficult at my age. Seriously.

 
Avatar Beltrán Rueda Administrator 3,714 post(s)

Hi,

The change is the following:

installdir/apps/wordpress/conf/wordpress.conf


Alias /Blog/ “/Applications/WordPress/apps/wordpress/htdocs/”
Alias /Blog “/Applications/WordPress/apps/wordpress/htdocs”
<Directory “/Applications/WordPress/apps/wordpress/htdocs”>
Options Indexes MultiViews +FollowSymLinks
AllowOverride All
Order allow,deny
Allow from all
</Directory>

It is not necessary to rename the wordpress directory. I hope it helps.

 
Avatar wordweaver 10 post(s)

Hello again Beltrán ,

Okay, I made the change in those two places as per your instructions.

Now, I can indeed access the blog at:

http://www.endtimeprophecy.net/Blog/

However, if I try to log in, or if I try to go to the admin panel, the URL is again defaulting to:

http://www.endtimeprophecy.net/wordpress/wp-log…

or . . .

http://www.endtimeprophecy.net/wordpress/wp-admin/

So apparently, there is still some other path that I need to change. Is the following line in wordpress.conf supposed to remain unchanged?

<Directory “/Applications/WordPress/apps/wordpress/htdocs”>

Also, in your previous instructions, there is no space between the second “Blog” and the quote mark. Was this intentional, or merely a typo on your part?

On your documentation page, there is also a section regarding changing the URL path in the mySQL database for WordPress. Is it possible that I need to do something like that as well?

If so, how would I access the mySQL installation in the installdir, and not in OS X’s built-in mySQL database?

If so, exactly what would I type? Perhaps this:

mysql -u root -p -e "USE bitnami_wordpress; UPDATE wp_options SET option_value=‘http://www.endtimeprophecy.net/Blog/’

I am just guessing here, but I am not going to make any changes until you instruct me further.

Thanks again!

 
Avatar Beltrán Rueda Administrator 3,714 post(s)

Also, in your previous instructions, there is no space between the second “Blog” and the quote mark. Was this intentional, or merely a typo on your part?

right, fixed

On your documentation page, there is also a section regarding changing the URL path in the mySQL database for WordPress. Is it possible that I need to do something like that as well?

Yes, you should also update the database according to your URL.

 
Avatar wordweaver 10 post(s)

Okay, that is what I thought . . . but how do I do that?

I am assuming that I have to use the Terminal to navigate to a particular folder, right?

So, which folder do I navigate to?

Would I do this in the Terminal:

cd /Applications/WordPress/mysql/data/bitnami_wordpress

After going there, would I type this in the Terminal:

mysql -u root -p -e "USE bitnami_wordpress; UPDATE wp_options SET option_value=‘http://www.endtimeprophecy.net/Blog/’

Well, I just tried navigating to that folder in the Terminal, but it won’t let me in, probably because it is owned by root. Even when I used “sudo” it still wouldn’t let me in.

I hope you have the correct solution.

 
Avatar Beltrán Rueda Administrator 3,714 post(s)

Try the following

$ cd /Applications/WordPress/mysql/bin
$ ./mysql -u root -p -e "USE bitnami_wordpress; UPDATE wp_options SET option_value=‘http://www.endtimeprophecy.net/Blog’"

 
Avatar wordweaver 10 post(s)

Hello Beltrán. Whenever I use that mySQL command string, my Terminal returns the following:

ERROR 1049 (42000) at line 1: Unknown database ‘bitnami_wordpress:’

I can’t remember now, but when I first installed the WordPress stack, was I given an option to name the database?

Also, there is a folder in mysql/data called “bitnami_wordpress” but I don’t have permissions for it.

Any ideas what the problem may be?

Thanks again. You are being really helpful, and I appreciate it.

 
Avatar Beltrán Rueda Administrator 3,714 post(s)

Maybe you write a colon instead of a semi-colon, could you check that?

 
Avatar wordweaver 10 post(s)

Hello Beltrán. You were right. I had placed a colon, instead of a semicolon, after “bitnami_wordpress”.

This time, when I entered the mySQL command, there was no error. In fact, as far as I can tell, nothing happened. I was just taken back to the directory that I was in; that is, mysql/bin. Is mySQL supposed to give me a confirmation in the Terminal that the path was properly changed in the database?

When I used Firefox on my other machine — not the host machine — to go to my domain at http://www.endtimeprophecy.net, I was presented with the “Access BitNami WordPress Stack” page. However, when I hover over the link, or click on the link, it still insists on taking me to “http://www.endtimeprophecy.net/wordpress/” which now throws me a 404 error. If I change the URL in Firefox to “http://www.endtimeprophecy.net/Blog/” Firefox presents me with a download window, and will then download a 0kb file called “Blog”.

I tried using Safari, and it does the very same thing. In other words, if I go to my domain at http://www.endtimeprophecy.net, I am presented with the “Access BitNami WordPress Stack” page. However, when I hover over the link, or click on the link, it still insists on taking me to “http://www.endtimeprophecy.net/wordpress/” which now throws me a 404 error. If I change the URL in Safari to “http://www.endtimeprophecy.net/Blog/” just like with Firefox, Safari downloads a 0kb file called “Blog”.

In short, even though I changed those two lines in the WordPress config file to say “Blog” instead of “wordpress”, and even though I used that mySQL command to supposedly change the mySQL database from “wordpress” to “Blog”, things are still not working right.

In fact, before I made the mySQL database change, things were a little better, because at least I could go to www.endtimeprophecy.net/Blog/. Now I can’t even do that, because it wants to download a 0kb file.

Also, while I hadn’t mentioned it before, when I install the stack as root — on either one of my machines — the “manager-osx” app no longer works. It refuses to launch. I am forced to use the command line to start and stop the servers now.

 
Avatar Beltrán Rueda Administrator 3,714 post(s)

Hi,

It is important that you add a slash at the end of the URL in the MySQL command: option_value=‘http://www.endtimeprophecy.net/Blog/’. Regards.

 
Avatar wordweaver 10 post(s)

Hello Beltrán. Adding a slash at the end of the URL when I make the change in the mySQL database is making no difference. Firefox still seems to recognize “Blog” as a file, and wants to download it, so there is still something that we are apparently missing.

I decided to delete the entire install directory and start over.

Once again I installed the WordPress stack as root so that I could connect on port 80.

Once the installation completed, I used Firefox to verify that the domain was accessible, and it was.

When I clicked on the Bitnami WordPress Stack link, it too me to the right page. Of course, this is while the path is set to its default of “wordpress”.

After that, I shut down Apache and mySQL, and I made those two changes in the wordpress.conf file, so that on those two lines it says “Blog” instead of “wordpress”.

Next, I restarted Apache and mySQL, and I went to “mysql/bin”.

After that, I made the change in the mySQL database using the following command:

./mysql -u root -p -e “USE bitnami_wordpress; UPDATE wp_options SET option_value=‘http://www.endtimeprophecy.net/Blog/’”

After doing this, I can still access my domain; however, if I try to go to “http://www.endtimeprophecy.net/Blog/” once again Firefox thinks that it is a file and wants to download “blog”, which results in a 0kb file.

So, even after reinstalling everything, the same problem continues to occur.

I really want to get this working right, but if I can’t, I may just decide to abandon it, and have a look at MAMP and MAMP Pro. My actual server and domains have had a lot of down time the past few days, just trying to get your stack to work right.

Can you offer any other ideas?

Thanks so much!

 
Avatar Beltrán Rueda Administrator 3,714 post(s)

Is it possible that you have in your main page a file called “blog” ?

 
Avatar wordweaver 10 post(s)

Hello Beltrán,

No, there is no file named “blog”.

It is my understanding that when a user goes to “www.endtimeprophecy.net/Blog”, their web browser should open the “index.php” file that is located in the main WordPress directory, or this case, in “wordpress/htdocs/”. There is no file in “htdocs” called “blog”.

Is it possible that something else needs to be changed in “wordpress.conf”?

As I asked you before, is there some way to verify that the path in the mySQL database was actually updated?

Also, as I asked before, why does the manager app refuse to launch when I install the stack as root?

 
Avatar Beltrán Rueda Administrator 3,714 post(s)

Hi,

As I asked you before, is there some way to verify that the path in the mySQL database was actually updated?

yes, you can login in the database and take a look to the table. You can use the phpMyAdmin application.

Also, as I asked before, why does the manager app refuse to launch when I install the stack as root?

You should run the manager application from a Terminal with root privileges:

$ sudo ./manager-osx.app/Contents/MacOS/installbuilder.sh

We will fix that in the future to throw a more detailed error.

 
Avatar wordweaver 10 post(s)

Hello Beltrán . I have never used phpMyAdmin before. I assumed that it is a GUI application, but apparently it is not.

I tried to run the phpMyAdmin app on the host machine by using Firefox on my personal machine, which is on the same LAN. I used “http://www.endtimeprophecy.net/phpMyAdmin”. However, I received a browser message saying that I had to use localhost or 127.0.0.1.

So, I went on the host machine, launched Firefox, and tried the same URL. This time, I was able to get to the login page. However, I cannot log in, because the login name and password are different.

In other words, I am assuming that what is happening, is that I am not really accessing the phpMyAdmin app that is a part of your Bitnami stack, rather, I am actually accessing the phpMyAdmin that is built into Mac OS X Tiger. And, I am thinking that phpMyAdmin is actually trying to log into the mySQL database that belongs to Tiger, and not to your Bitnami stack.

So, would I be correct to assume that — as with everything else — I need to use the Terminal on the host machine to actually run the phpMyAdmin app that is a part of your stack, as well as to log into the mySQL database that is a part of your stack?

If this is correct, can you please explain to me how to do it? I assume that I have to cd to /Applications/WordPress/apps/phpMyAdmin in the Terminal.

Then what do I do? What do I type in the Terminal after navigating to the phpMyAdmin folder?

After I do get into the mySQL database, where do I look to verify that the path has been changed from “http://www.endtimeprophecy.net/wordpress/” to “http://www.endtimeprophecy.net/Blog/”?

I hope that we can get this working properly soon, as I am close to giving up. This is not as easy as I thought it would be, and I am not finding this “refreshingly simple”. Of course, I am sure that has a lot to do with the fact that I am not really a Terminal person, and my knowledge concerning PHP and mySQL is near zero. This would probably be a lot easier if I was more knowledgeable.

Thanks so much for your time and patience. I appreciate it.

 
Avatar Beltrán Rueda Administrator 3,714 post(s)

Hi,

You can access to phpMyAdmin from th http://127.0.0.1/phpmyadmin in the same machine you installed it. Then you can login using the “root” user and then the password that you set during the installation.

I’m sorry you are finding a lot of problems but change the URL for wordpress should not be so difficult.

 
Avatar wordweaver 10 post(s)

Hello Beltrán,

Thank-you for all of your help. It has been appreciated.

While the Bitnami WordPress stack is a very nice package, it has simply proven to be a bit too difficult for me to understand and set up properly, due in large part to my own lack of knowledge and experience with the Terminal, PHP and mySQL.

As a result, since yesterday, I have successfully installed MAMP Pro, and now have four domains running under it, along with my WordPress blog, some messageboards, and a few other things.

Thanks again for your time. I know that you tried to help me the best that you could.

 
Avatar Beltrán Rueda Administrator 3,714 post(s)

Thanks for your feedback! We are working to improve our Stacks.

Forums WordPress