Magento Follow www.magento.com | Open Source

The Bitnami Magento Stack provides a one-click install solution for Magento. Download installers and virtual machines, or run your own Magento server in the cloud.

Magento is one of the most popular open source ecommerce shopping cart systems. It is extremely flexible and has a huge variety of features to build just about any store. Features include SEO-readiness, multi-store support, marketing tools, deep analytics, catalog management, a robust shopping cart with support for multiple shipping addresses and more. The Magento project is backed by eBay, so you can be confident that it will be around for the long run, and it offers multiple editions, including small business and enterprise editions, to help grow with your business.


Why use the Bitnami Magento Stack?

Bitnami makes it easy to run Magento in the cloud, locally or virtually. The Bitnami Magento Stack is:

  • Up-to-date

    We track every release of Magento and update our stack shortly after it's released.

  • Secure

    If serious security issues are discovered, we provide new versions of Magento as soon as possible, often within hours of the availability of a fix.

  • Consistent

    With Bitnami, you get the same software stack and configuration regardless of where you are deploying Magento or other Bitnami Applications. This makes it easy to migrate between different platforms.

With the Bitnami Magento Stack compiling, configuring and all of its dependencies are taken care of, so it works out-of-the-box.

Back to top

Reviews of Bitnami Magento Write a Review →

  1. Bitnami Magento 5

    This is excellent!

    by Gabriel Palhares on

    Excellent product, the easiest way to install Magento! Thank you.

    People having issues with Windows, don't forget to execute setup file and Stack Manager Tool app as administrator.

    Was this review helpful to you? Yes No

  2. Bitnami Magento 2

    Older versions?!

    by B. H. on

    Where are older version of Magento like 1.9.x?

    Think you should share this too!

    It's crazy... some products are only available in the current version for others only in old versions.

    7 out of 8 people found this helpful.

    Was this review helpful to you? Yes No

  3. Bitnami Magento 1

    Installation crash

    by Livio Paciotti on

    I try install Magento module:

    bitnami-magento-2.1.6-0-module-linux-x64-installer.run

    On stack

    bitnami-lampstack-7.1.2-1-dev-linux-x64-installer.run

    but i have this error :

    "Problem running post-install step. Installation may not complete

    correctly

    Error running /opt/lampstack-7.1.2-1/php/bin/php -q

    "/opt/lampstack-7.1.2-1/apps/magento/htdocs/bin/magento" setup:install

    --base-url "http://127.0.1.1/magento" --backend-frontname "admin" --db-host

    "/opt/lampstack-7.1.2-1/mysql/tmp/mysql.sock" --db-name "bitnami_magento"

    --db-user "bn_magento" --db-password "2727d0d99e" --admin-firstname "pl"

    --admin-lastname "Bitnami" --admin-email "plhmk@tin.it" --admin-user "pl"

    --admin-password "manamana1" --language "en_US" --currency "USD" --timezone

    "America/Los_Angeles" --use-secure "1" --base-url-secure

    "https://127.0.1.1/magento/" --use-secure-admin "0":

    "

    So the application don't start

    4 out of 4 people found this helpful.

    Was this review helpful to you? Yes No

  4. Bitnami Magento 1

    Do not waste your time trying

    by Lain Iawkura on

    I say this because while it "might" work, the php version is listed on Magento as non-compatible. I discovered this while trying to install a Magento 2.1.5 on my WAMP which also has the same problem, Bitnami has dropped the ball on this big time, cant even read the Magento requirements before they make a stack...very unhappy right now.

    1 out of 1 people found this helpful.

    Was this review helpful to you? Yes No

  5. Bitnami Magento 1

    Magento fine....But Bitnami must be crazy?

    by Lain Iawkura on

    I have been developing Magento sites on Bitnami stacks locally for years..love them. UNTIL now. As a self taught developer even I am smart enough to ensure that the PHP versions used in the stack are compatible with Magento....evidently though, Bitnami is NOT. If your having problems its because php 7.0.16 IS NOT COMPATIBLE with Magento 2.1.5

    Furthermore in what has to be a crazy stoke of dumb, NONE of the WAMP stacks have compatible php versions either, the last one that did 7.0.14 is no longer available for download....Thanks Bitnami, you went from GOD to OMG in one fell stroke of stupid.

    1 out of 1 people found this helpful.

    Was this review helpful to you? Yes No