Ruby Follow www.ruby-lang.org | Open Source

Bitnami Ruby Stack provides a complete, ready-to-run development environment for Ruby on Rails. It includes the latest stable release of Ruby, Rails, RVM, MySQL, SQLite, NGINX, Apache, Memcache and Varnish, Git and Subversion, Sphinx, PHP and phpMyAdmin. It also includes most popular gems for building Rails applications: Thin, RMagick, Rake, Mongrel, Passenger, Nokogiri and more. It also includes libraries such as OpenSSL, openLDAP, CURL, ImageMagick and more.

Download installers and virtual machines, or run your own Ruby server in the cloud.


Why use the Bitnami Ruby Stack?

Bitnami makes it easy to run Ruby in the cloud, locally or virtually. The Bitnami Ruby Stack is:

  • Up-to-date

    We track every release of Ruby and update our stack shortly after it's released.

  • Secure

    If serious security issues are discovered, we provide new versions of Ruby as soon as possible, often within hours of the availability of a fix.

  • Consistent

    With Bitnami, you get the same software stack and configuration regardless of where you are deploying Ruby or other Bitnami Applications. This makes it easy to migrate between different platforms.

With the Bitnami Ruby Stack compiling, configuring and all of its dependencies are taken care of, so it works out-of-the-box.

Back to top

Reviews of Bitnami Ruby Write a Review →

  1. Bitnami Ruby 1

    just getting these kind of stuff

    by Dansh Raaj on

    i have downloaded ruby stack version 2.3.4-1. in changelog it says php is updated to 7.0.18 but when i checked running phpinfo after install it shows 5.6.30 version

    Was this review helpful to you? Yes No

    Sorry! This is a mistake in the Changelog. Ruby Stack 2.4.x bundles PHP 7, Ruby Stack 2.3.x bundles PHP 5. We will update the Changelog with the next release. We apologize for the inconvenience.
    by Bitnami Staff on
  2. Bitnami Ruby 3

    Up to date?? Not the case but works somewhat...

    by Stephen Smith on

    Downloaded the latest for Windows (2.2.6) but it actually installs 2.2.5p319. What's going on? Also, 2.3.3 is the latest for Windows AFAIK? As soon as you do 'gem install my_gem' you immediately get an SSL error. Google the error and you'll find the fix - basically an update to rubygems from 2.4.x to 2.6.x will fix it. The rubygems page says 2.4.x is broken on Windows, so why use 2.4.x?. The purpose of this stack is to install a working ruby infrastructure on Windows - almost a complete fail in my opinion if the gem command doesn't work (ruby works so I gave a point for that). For new users who aren't technical this might be a deal breaker. Documentation is out of date as well - postgresql gets installed but not mentioned in readme file (partial mention but incorrectly titles it as MySQL). Overall, love this idea of a pre-installed stack but c'mon guys, make sure the 'gem' command works, keep the docs up to date, and don't say 'up to date' if your product versions are not. Details, details, they're important. :-)

    1 out of 1 people found this helpful.

    Was this review helpful to you? Yes No

  3. Bitnami Ruby 1

    Failure in both 2.3.1, and 2.2.5

    by Santanu Karmakar on

    /home/bitnami/stack/projects/shared/bundle/ruby/2.2.0/bin/rake: symbol lookup error: /home/bitnami/stack/projects/shared/bundle/ruby/2.2.0/extensions/x86_64-linux/2.2.0-static/pg-0.18.2/pg_ext.so: undefined symbol: rb_thread_select

    Was this review helpful to you? Yes No

  4. Bitnami Ruby 1

    dev ? do you testted it?

    by qx oy on

    /opt/rubystack-2.3.1-0/ruby/bin/.ruby.bin: symbol lookup error: /opt/rubystack-2.3.1-0/ruby/lib/ruby/gems/2.3.0/gems/pg-0.18.4/lib/pg_ext.so: undefined symbol: rb_thread_select

    1 out of 1 people found this helpful.

    Was this review helpful to you? Yes No

  5. Bitnami Ruby 4

    2.3.1 version can not run in ubuntu 12.04

    by qx oy on

    pg undefined symbol: rb_thread_select,

    "rb_thread_select" error many times,please check it . may I use rvm ruby?

    If so ,how can I replace bitnami's ruby

    1 out of 1 people found this helpful.

    Was this review helpful to you? Yes No